Apache 2.2 < 2.2.18 APR apr_fnmatch DoS

This script is Copyright (C) 2011-2014 Tenable Network Security, Inc.


Synopsis :

The remote web server may be affected by a denial of service
vulnerability.

Description :

According to its banner, the version of Apache 2.2 installed on the
remote host is older than 2.2.18. Such versions are affected by a
denial of service vulnerability due to an error in the 'apr_fnmatch'
match function of the bundled APR library.

If mod_autoindex is enabled and has indexed a directory containing
files whose filenames are long, an attacker can cause high CPU usage
with a specially crafted request.

Note that the remote web server may not actually be affected by this
vulnerability. Nessus did not try to determine whether the affected
module is in use or to check for the issue itself.

See also :

http://www.nessus.org/u?5582384f
http://httpd.apache.org/security/vulnerabilities_22.html#2.2.18
http://securityreason.com/achievement_securityalert/98

Solution :

Either ensure the 'IndexOptions' configuration option is set to
'IgnoreClient' or upgrade to Apache version 2.2.18 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 3.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 53896 ()

Bugtraq ID: 47820

CVE ID: CVE-2011-0419