MyBB xmlhttp.php value Parameter XSS

This script is Copyright (C) 2011-2014 Tenable Network Security, Inc.


Synopsis :

The remote web server hosts a web application that is affected by a
cross-site scripting vulnerability.

Description :

The version of MyBB installed on the remote host is affected by a
cross-site scripting vulnerability involving the 'value' parameter of
the 'xmlhttp.php' script. A remote attacker may be able to exploit
this by tricking a user into making a specially crafted GET request.

Note that the installed version of MyBB may also be affected by
another cross-site scripting vulnerability, though Nessus has not
tested for that.

See also :

http://blog.mybb.com/2011/02/22/mybb-1-6-2-and-1-4-15-security-update/
http://dev.mybb.com/issues/1460

Solution :

Upgrade to MyBB 1.4.15 / 1.6.2 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 4.1
(CVSS2#E:F/RL:U/RC:ND)
Public Exploit Available : true

Family: CGI abuses : XSS

Nessus Plugin ID: 53288 ()

Bugtraq ID: 47131

CVE ID: