Apache Tomcat < 6.0.32 / 7.0.8 NIO Connector Denial of Service

This script is Copyright (C) 2011-2014 Tenable Network Security, Inc.


Synopsis :

The remote web server may be affected by a denial of service
vulnerability.

Description :

According to its self-reported version number, the instance of Apache
Tomcat listening on the remote host is less than 6.0.32 / 7.0.8 and as
such, may be affected by a denial of service vulnerability.

An error, involving the NIO HTTP connector, exists such that the limit
'maxHttpHeaderSize' is not enforced thereby allowing a denial of
service condition when memory is exhausted.

Note that Nessus did not actually test for the flaws but instead has
relied on the version in Tomcat's banner or error page.

See also :

http://www.nessus.org/u?1fba1931
http://www.nessus.org/u?4b1a5833
http://www.nessus.org/u?daf049a2

Solution :

Update Apache Tomcat to version 6.0.32 / 7.0.8 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 4.3
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 51987 ()

Bugtraq ID: 46164

CVE ID: CVE-2011-0534