Apache Tomcat 5.5.x < 5.5.32 HTML Manager Interface XSS

This script is Copyright (C) 2011-2014 Tenable Network Security, Inc.


Synopsis :

The remote web server is susceptible to a cross-site scripting attack.

Description :

According to its self-reported version number, the instance of Apache
Tomcat 5.5.x listening on the remote host is earlier than 5.5.32 and
as such, is reportedly affected by a cross-site scripting
vulnerability in its HTML Manager interface.

An input validation error exists in the HTML Manager interface of
Tomcat that may allow a remote attacker to inject code into a user's
browser via a crafted URL.

Note that Nessus did not actually test for the flaw but instead has
relied on the version in Tomcat's banner or error page.

See also :

http://tomcat.apache.org/security-5.html#Fixed_in_Apache_Tomcat_5.5.32
http://archives.neohapsis.com/archives/fulldisclosure/current/0077.html

Solution :

Upgrade to Apache Tomcat version 5.5.32 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 3.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 51957 ()

Bugtraq ID: 46174

CVE ID: CVE-2011-0013