OpenSSL OCSP Stapling Denial of Service

This script is Copyright (C) 2011-2013 Tenable Network Security, Inc.


Synopsis :

The remote web server has an SSL-related denial of service
vulnerability.

Description :

According to its banner, the remote web server is running a version
of OpenSSL older than 0.9.8r or 1.0.0d.

Incorrectly formatted ClientHello handshake messages could cause
OpenSSL to parse past the end of the message. This could cause the
web server to crash. There is also the potential for information
disclosure if OCSP nonce extensions are used.

See also :

http://www.openssl.org/news/secadv_20110208.txt
http://cvs.openssl.org/chngview?cn=20359

Solution :

Upgrade to OpenSSL 0.9.8r / 1.0.0d or later.

Risk factor :

Medium / CVSS Base Score : 6.4
(CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P)
CVSS Temporal Score : 5.6
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 51919 ()

Bugtraq ID: 46264

CVE ID: CVE-2011-0014