Exim < 4.74 Local Privilege Escalation

This script is Copyright (C) 2011-2014 Tenable Network Security, Inc.


Synopsis :

The remote mail server is potentially affected by a local privilege
escalation vulnerability.

Description :

The remote host is running Exim, a message transfer agent.

According to the version number in its banner, the installed version
of Exim is earlier than 4.74 and thus potentially affected by a local
privilege escalation vulnerability.

If the remote host is running Linux, attackers can exploit this issue
to append arbitrary data to files through symbolic link attacks.
Successfully exploiting this issue allows local attackers with 'exim'
run-time user privileges to perform certain actions with superuser
privileges, leading to a complete compromise of an affected computer.

See also :

ftp://ftp.exim.org/pub/exim/ChangeLogs/ChangeLog-4.74
http://lists.exim.org/lurker/message/20110126.034702.4d69c278.en.html

Solution :

Upgrade to Exim 4.74 or later.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:L/AC:L/Au:S/C:C/I:C/A:C)
CVSS Temporal Score : 5.9
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: SMTP problems

Nessus Plugin ID: 51861 ()

Bugtraq ID: 46065

CVE ID: CVE-2011-0017