ProFTPD < 1.3.3d 'mod_sql' Buffer Overflow

This script is Copyright (C) 2010-2014 Tenable Network Security, Inc.


Synopsis :

The remote FTP server is affected by a heap-based buffer overflow
vulnerability.

Description :

The remote host is using ProFTPD, a free FTP server for Unix and
Linux.

According to its banner, the version of ProFTPD installed on the
remote host is earlier than 1.3.3d. Such versions are reportedly
affected by a heap-based buffer overflow vulnerability in the function
'sql_prepare_where()' in the file 'contrib/mod_sql.c'. An
unauthenticated, remote attacker may be able to exploit this in
combination with an earlier SQL injection vulnerability
(CVE-2009-0542) to execute arbitrary code with root privileges.

Note that Nessus did not actually test for the flaw but instead has
relied on the version in ProFTPD's banner.

See also :

http://phrack.org/issues.html?issue=67&id=7#article
http://bugs.proftpd.org/show_bug.cgi?id=3536
http://www.proftpd.org/docs/RELEASE_NOTES-1.3.3d

Solution :

Upgrade to ProFTPD version 1.3.3d or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.3
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: FTP

Nessus Plugin ID: 51366 ()

Bugtraq ID: 44933

CVE ID: CVE-2010-4652