ClamAV < 0.96.5 Multiple Vulnerabilities

This script is Copyright (C) 2010-2014 Tenable Network Security, Inc.


Synopsis :

The remote antivirus service is affected by multiple vulnerabilities.

Description :

According to its version, the clamd antivirus daemon on the remote
host is earlier than 0.96.5. Such versions are reportedly affected by
multiple vulnerabilities :

- Multiple errors exist in the PDF processing functions in
'libclamav/pdf.c', which could lead to application
crashes. (Bugs 2358, 2380, 2396)

- An off-by-one error exists in the handling of icons such
that a crafted icon may be used to cause an integer
overflow. (Bug 2344)

See also :

http://www.nessus.org/u?fe2848b9
http://www.nessus.org/u?e9a63cb5
http://www.nessus.org/u?87149641
http://www.nessus.org/u?022c6883
http://freshmeat.net/projects/clamav/releases/325193

Solution :

Upgrade to ClamAV 0.96.5 or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.5
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 51125 ()

Bugtraq ID: 45152

CVE ID: CVE-2010-4260
CVE-2010-4261
CVE-2010-4479