QuickTime < 7.6.9 Multiple Vulnerabilities (Mac OS X)

This script is Copyright (C) 2010-2012 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host contains an application that is affected by
multiple vulnerabilities.

Description :

The version of QuickTime installed on the remote Mac OS X host is
older than 7.6.9. Such versions contain several vulnerabilities :

- A heap buffer overflow in QuickTime's handling of JP2
images may lead to an application crash or arbitrary
code execution. (CVE-2010-3787)

- Uninitialized memory access issues in QuickTime's
handling of JP2, FlashPix, and GIF images may lead to
an application crash or arbitrary code execution.
(CVE-2010-3788, CVE-2010-3794, CVE-2010-3795)

- Memory corruption issues in QuickTime's handling of
AVI files, movie files, Sorenson encoded movie files,
PICT files, FlashPix images, and panorama atoms in QTVR
(QuickTime Virtual Reality) movie files may lead to an
application crash or arbitrary code execution.
(CVE-2010-3789, CVE-2010-3790, CVE-2010-3793,
CVE-2010-3800, CVE-2010-3801, CVE-2010-3802)

- A buffer overflow in QuickTime's handling of MPEG-
encoded movie files may lead to an application crash or
arbitrary code execution. (CVE-2010-3791)

- A signedness issue in QuickTime's handling of MPEG-
encoded movie files may lead to an application crash or
arbitrary code execution. (CVE-2010-3792)

- An integer overflow in QuickTime's handling of movie
files may lead to an application crash or arbitrary
code execution. (CVE-2010-4009)

See also :

http://support.apple.com/kb/HT4447
http://lists.apple.com/archives/security-announce/2010/Dec/msg00000.html

Solution :

Upgrade to QuickTime 7.6.9 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false