CUPS < 1.4.5 Multiple Vulnerabilities

This script is Copyright (C) 2010-2016 Tenable Network Security, Inc.


Synopsis :

The remote print service is affected by multiple vulnerabilities.

Description :

According to its banner, the version of CUPS installed on the remote
host is prior to 1.4.5. It is, therefore, affected by multiple
vulnerabilities :

- A use-after-free error exists due to improper allocation
of memory for attribute values with invalid string data
types. A remote attacker can exploit this, via a crafted
IPP request, to cause a denial of service condition or
the execution of arbitrary code. (CVE-2010-2941)

- An overflow condition exists in the PPD compiler due to
improper validation of user-supplied input. A remote
attacker can exploit this to dereference already freed
memory, resulting in the execution of arbitrary code.
(VulnDB 135458)

See also :

https://bugzilla.redhat.com/show_bug.cgi?id=624438
https://www.cups.org/blog.php?L597+I60+Q

Solution :

Upgrade to CUPS version 1.4.5 or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.4
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 50844 ()

Bugtraq ID: 44530

CVE ID: CVE-2010-2941