Adobe Flash Media Server < 3.0.7 / 3.5.5 / 4.0.1 Multiple Vulnerabilities (APSB10-27)

This script is Copyright (C) 2010-2012 Tenable Network Security, Inc.


Synopsis :

The remote media server is affected by multiple vulnerabilities.

Description :

The remote host is running Adobe Flash Media Server, an application
server for Flash-based applications.

The version running on the remote host is earlier than version 3.0.7,
3.5.5, or 4.0.1. Such versions are potentially affected by the
following vulnerabilities :

- The server is vulnerable to a denial of service attack
due to an unspecified memory leak error. (CVE-2010-3633)

- The server is vulnerable to a denial of service attack
due to an unspecified error in the server's
'edge process'.(CVE-2010-3634)

- An unspecified error exists that can allow an attacker
to cause a segmentation fault and may lead to arbitrary
code execution. (CVE-2010-3635)

See also :

http://www.adobe.com/support/security/bulletins/apsb10-27.html

Solution :

Upgrade to Flash Media Server 3.0.7, 3.5.5, 4.0.1 or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.4
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 50562 ()

Bugtraq ID: 44757
44756
44753

CVE ID: CVE-2010-3633
CVE-2010-3634
CVE-2010-3635