cformsII Plugin for WordPress rs Parameter XSS

This script is Copyright (C) 2010-2013 Tenable Network Security, Inc.


Synopsis :

The remote web server hosts a PHP script that is vulnerable to a
cross-site scripting attack.

Description :

The version of the cformsII plugin for WordPress hosted on the remote
web server fails to sanitize user-supplied input to the 'rs' parameter
of the 'lib_ajax.php' script before using it to generate dynamic HTML
output.

An attacker may be able to leverage this issue to inject arbitrary
HTML or script code into a user's browser to be executed within the
security context of the affected site.

Note that the install is also likely to be vulnerable to a similar
cross-site scripting attack involving the 'rsargs' parameter, although
Nessus has not checked for that.

See also :

http://www.securityfocus.com/archive/1/514579/30/0/threaded

Solution :

Unknown at this time.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 3.6
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: CGI abuses : XSS

Nessus Plugin ID: 50512 ()

Bugtraq ID: 44587

CVE ID: CVE-2010-3977