Apache Tomcat 4.x < 4.1.0 Multiple Vulnerabilities

This script is Copyright (C) 2010-2015 Tenable Network Security, Inc.

Synopsis :

The remote Apache Tomcat service may be affected by multiple

Description :

According to its self-reported version number, the instance of Apache
Tomcat 4.x listening on the remote host is earlier than 4.1.0 and, as
such, may be affected by multiple vulnerabilities.

- An error exists in the handling of malformed packets
that can cause the processing thread to become
unresponsive. A sequence of such requests can cause all
threads to become unresponsive. (CVE-2003-0866)

- Two example servlets, 'snoop' and a trouble shooting
servlet, disclose the Apache Tomcat installation path.

- It has also been reported that this version of Tomcat
is affected by a cross-site scripting vulnerability.
The contents of a request URL are not sanitized before
being returned to the browser should an error occur.

Note that Nessus did not actually test for the flaws but instead has
relied on the version in Tomcat's banner or error page so this may be
a false positive.

See also :


Solution :

Update to Apache Tomcat version 4.1.0 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
CVSS Temporal Score : 3.7
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 50475 ()

Bugtraq ID: 4575

CVE ID: CVE-2003-0866