Apache Tomcat 3.x < 3.2.2 JSP Error Condition XSS

This script is Copyright (C) 2010-2014 Tenable Network Security, Inc.


Synopsis :

The remote Apache Tomcat service is affected by a cross-site
scripting vulnerability.

Description :

The instance of Apache Tomcat 3.x listening on the remote host is
affected by a cross-site scripting vulnerability. An attacker is able
to embed JavaScript into a request for a JSP file creating an error
condition. The request is not sanitized before being displayed on the
application error page.

See also :

http://tomcat.apache.org/security-3.html#Fixed_in_Apache_Tomcat_3.2.2
http://www.mail-archive.com/tomcat-dev@jakarta.apache.org/msg06679.html

Solution :

Update to Apache Tomcat version 3.2.2 or later.

Risk factor :

Medium / CVSS Base Score : 5.1
(CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.1
(CVSS2#E:H/RL:U/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 50448 ()

Bugtraq ID: 2982

CVE ID: CVE-2001-0829