Apache Tomcat 4.x < 4.1.3 Denial of Service

This script is Copyright (C) 2010-2014 Tenable Network Security, Inc.

Synopsis :

The remote Apache Tomcat service may be affected by a denial of
service vulnerability.

Description :

According to its self-reported version number, the instance of Apache
Tomcat 4.x listening on the remote host is earlier than 4.1.3 and, as
such, may be affected by a denial of service vulnerability.

A malicious HTTP request can cause a request processing thread to
become unresponsive. Further requests of this type can cause all
request processing threads to become unresponsive.

Note that Nessus did not actually test for the flaws but instead has
relied on the version in Tomcat's banner or error page so this may be
a false positive.

See also :


Solution :

Update to Apache Tomcat version 4.1.3 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
CVSS Temporal Score : 4.3
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 49702 ()

Bugtraq ID: 5067

CVE ID: CVE-2002-0935