Squid < 3.1.8 / 3.2.0.2 NULL Pointer Dereference Denial of Service

This script is Copyright (C) 2010-2014 Tenable Network Security, Inc.


Synopsis :

The remote proxy server is affected by a denial of service
vulnerability.

Description :

According to its banner, the version of Squid is 3.x earlier than than
3.1.8, or 3.2.x earlier than 3.2.0.2. Such versions are potentially
affected by a denial of service vulnerability caused by an internal
error in string handling. A remote attacker, exploiting this flaw,
could crash the affected service.

Note that Nessus has relied only on the version in the proxy server's
banner, which is not updated by either of the patches the project has
released to address the issue. If one of those has been applied
properly and the service restarted, consider this to be a false
positive.

See also :

http://www.squid-cache.org/Advisories/SQUID-2010_3.txt

Solution :

Upgrade to Squid version 3.1.8 / 3.2.0.2 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 4.1
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Firewalls

Nessus Plugin ID: 49693 ()

Bugtraq ID: 42982

CVE ID: CVE-2010-3072