Adobe Flash Media Server < 3.0.6 / 3.5.4 Multiple Vulnerabilities (APSB10-19)

This script is Copyright (C) 2010-2012 Tenable Network Security, Inc.


Synopsis :

The remote media server is affected by multiple vulnerabilities.

Description :

The remote host is running Adobe Flash Media Server, an application
server for Flash-based applications.

The version running on the remote host is earlier than version 3.0.6
or 3.5.4. Such versions are potentially affected by the following
vulnerabilities :

- An issue in a JS method could result in a denial of
service condition. (CVE-2010-2218)

- An issue in a JS method could allow arbitrary code
execution. (CVE-2010-2217)

- A memory exhaustion issue could lead to a denial of
service condition. (CVE-2010-2219)

- A input validation issue could lead to a denial of
service condition. (CVE-2010-2220)

See also :

http://www.adobe.com/support/security/bulletins/apsb10-19.html

Solution :

Upgrade to Flash Media Server 3.0.6, 3.5.4 or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.4
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 48298 (adobe_fms_3_5_4.nasl)

Bugtraq ID: 42352
42354
42356
42357

CVE ID: CVE-2010-2217
CVE-2010-2218
CVE-2010-2219
CVE-2010-2220