Apache 2.2 < 2.2.16 Multiple Vulnerabilities

This script is Copyright (C) 2010-2013 Tenable Network Security, Inc.


Synopsis :

The remote web server is affected by multiple vulnerabilities.

Description :

According to its banner, the version of Apache 2.2 installed on the
remote host is older than 2.2.16. Such versions are potentially
affected by multiple vulnerabilities :

- A denial of service vulnerability in mod_cache and
mod_dav. (CVE-2010-1452)

- An information disclosure vulnerability in mod_proxy_ajp,
mod_reqtimeout, and mod_proxy_http relating to timeout
conditions. Note that this issue only affects Apache on
Windows, Netware, and OS/2. (CVE-2010-2068)

Note that the remote web server may not actually be affected by these
vulnerabilities. Nessus did not try to determine whether the affected
modules are in use or to check for the issues themselves.

See also :

http://httpd.apache.org/security/vulnerabilities_22.html
https://issues.apache.org/bugzilla/show_bug.cgi?id=49246
https://issues.apache.org/bugzilla/show_bug.cgi?id=49417
http://www.nessus.org/u?ce8ac446

Solution :

Upgrade to Apache version 2.2.16 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N)
CVSS Temporal Score : 4.1
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 48205 (apache_2_2_16.nasl)

Bugtraq ID: 40827
41963

CVE ID: CVE-2010-1452
CVE-2010-2068