Apache Tomcat 4.1 XSS

This script is Copyright (C) 2010-2016 Tenable Network Security, Inc.


Synopsis :

The remote web server is affected by a cross-site scripting
vulnerability.

Description :

The version of Apache Tomcat running on the remote web server is
affected by a cross-site scripting vulnerability due to a failure to
properly sanitize request strings of malicious JavaScript. A remote,
unauthenticated attacker can exploit this to execute arbitrary code by
using a URL containing encoded newline characters that are followed by
a request to a .jsp file that has a crafted file name.

See also :

http://archives.neohapsis.com/archives/vuln-dev/2002-q3/0482.html
http://tomcat.apache.org/security-4.html

Solution :

Upgrade to Apache Tomcat version 4.1.29 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 4.3
(CVSS2#E:H/RL:U/RC:ND)
Public Exploit Available : true

Family: CGI abuses : XSS

Nessus Plugin ID: 47715 ()

Bugtraq ID: 5542

CVE ID: CVE-2002-1567

Ready to Scan Unlimited IPs & Run Compliance Checks?

Upgrade to Nessus Professional today!

Buy Now

Combine the Power of Nessus with the Ease of Cloud

Start your free Nessus Cloud trial now!

Begin Free Trial