MySQL Community Server < 5.1.48 Denial of Service

This script is Copyright (C) 2010-2014 Tenable Network Security, Inc.


Synopsis :

The remote database server is affected by denial of service
vulnerability.

Description :

The version of MySQL Community Server installed on the remote host is
earlier than 5.1.48 and thus potentially affected by a denial of
service vulnerability.

The 'ALTER DATABASE' command can be misused by a user with 'ALTER'
permissions to cause the MySQL data directory to become unusable.

See also :

http://bugs.mysql.com/bug.php?id=53804
http://dev.mysql.com/doc/refman/5.1/en/news-5-1-48.html

Solution :

Upgrade to MySQL Community Server 5.1.48 or later.

Risk factor :

Low / CVSS Base Score : 3.5
(CVSS2#AV:N/AC:M/Au:S/C:N/I:N/A:P)
CVSS Temporal Score : 2.9
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Databases

Nessus Plugin ID: 47158 ()

Bugtraq ID: 41198

CVE ID: CVE-2010-2008