Samba 3.x < 3.3.13 SMB1 Packet Chaining Memory Corruption

This script is Copyright (C) 2010-2014 Tenable Network Security, Inc.


Synopsis :

The remote service is affected by a memory corruption vulnerability.

Description :

According to its banner, the version of Samba running on the remote
host is a version of 3.x before 3.3.13. Such versions are affected by
a memory corruption vulnerability when handling specially crafted SMB1
packets.

By exploiting this flaw, a remote, unauthenticated attacker could
crash the affected service or potentially execute arbitrary code
subject to the privileges of the user running the affected
application.

See also :

http://www.samba.org/samba/security/CVE-2010-2063.html
http://www.samba.org/samba/history/security.html

Solution :

Upgrade to Samba 3.3.13 or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.5
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 47036 ()

Bugtraq ID: 40884

CVE ID: CVE-2010-2063