Novell eDirectory < 8.8 SP5 Patch 4 Multiple Vulnerabilities

This script is Copyright (C) 2010-2012 Tenable Network Security, Inc.


Synopsis :

The remote directory service is affected by multiple
vulnerabilities.

Description :

The remote host is running eDirectory, a directory service software
from Novell. The installed version of this software is affected by
one or more of the following vulnerabilities :

- A denial of service vulnerability in NDSD when handling
a malformed verb. (Bug 571244)

- A stack-based buffer overflow in the dhost module
for Windows. (Bug 588883)

- A predictable session cookie in DHOST. (Bug 586854)

See also :

http://www.novell.com/support/viewContent.do?externalId=3426981
http://www.securityfocus.com/archive/1/507812/100/0/threaded

Solution :

Upgrade to eDirectory 8.8 SP5 Patch 4 or later.

Risk factor :

High / CVSS Base Score : 9.0
(CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:POC/RL:U/RC:ND)
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 47022 (edirectory_88sp5_patch4.nasl)

Bugtraq ID: 37009
40541

CVE ID: CVE-2009-4653