GLSA-201006-03 : ImageMagick: User-assisted execution of arbitrary code

This script is Copyright (C) 2010-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-201006-03
(ImageMagick: User-assisted execution of arbitrary code)

Tielei Wang has discovered that the XMakeImage() function in
magick/xwindow.c is prone to an integer overflow, possibly leading to a
buffer overflow.

Impact :

A remote attacker could entice a user to open a specially crafted
image, possibly resulting in the remote execution of arbitrary code
with the privileges of the user running the application, or a Denial of
Service.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-201006-03.xml

Solution :

All ImageMagick users should upgrade to an unaffected version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=media-gfx/imagemagick-6.5.2.9'
NOTE: This is a legacy GLSA. Updates for all affected architectures are
available since June 4, 2009. It is likely that your system is already
no longer affected by this issue.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Gentoo Local Security Checks

Nessus Plugin ID: 46770 (gentoo_GLSA-201006-03.nasl)

Bugtraq ID: 35111

CVE ID: CVE-2009-1882