Squid < 3.0.STABLE24 / 2.7.STABLE8 / 2.6.STABLE24

This script is Copyright (C) 2010-2014 Tenable Network Security, Inc.


Synopsis :

The remote proxy server is prone to a denial of service attack.

Description :

According to its banner, the version of the Squid proxy caching server
installed on the remote host is older than 3.0.STABLE24 / 2.7.STABLE8
/ 2.6.STABLE24. Such versions de-reference a NULL pointer while
handling certain Hypertext Caching Protocol (HTCP) requests.

This mishandling can be abused by a remote attacker to cause a denial
of service by sending specially crafted HTCP requests to an affected
service.

Note that Nessus has relied only on the version in the proxy server's
banner, which is not updated by either of the patches the project has
released to address this issue. If one of those has been applied
properly and the service restarted, consider this to be a false
positive.

See also :

http://www.squid-cache.org/Advisories/SQUID-2010_2.txt
http://www.squid-cache.org/Versions/v2/2.7/changesets/12600.patch
http://www.nessus.org/u?f56c919c

Solution :

Either upgrade to Squid version 3.0.STABLE24 / 2.7.STABLE8 /
2.6.STABLE24 or later or apply the appropriate patch referenced in the
project's advisory above.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 4.1
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Firewalls

Nessus Plugin ID: 45591 ()

Bugtraq ID: 38212

CVE ID: CVE-2010-0639