MS10-026: Vulnerability in Microsoft MPEG Layer-3 Codecs Could Allow Remote Code Execution (977816)

This script is Copyright (C) 2010-2013 Tenable Network Security, Inc.


Synopsis :

An audio codec on the remote Windows host has a buffer overflow
vulnerability.

Description :

The Microsoft MPEG Layer-3 (MP3) codecs have a buffer overflow
vulnerability that is triggered by opening a specially crafted AVI
file with an MP3 audio stream.

A remote attacker could exploit this by tricking a user into opening a
malicious AVI file, which would lead to arbitrary code execution.

See also :

http://technet.microsoft.com/en-us/security/bulletin/MS10-026

Solution :

Microsoft has released a set of patches for Windows 2000, XP, 2003,
Vista, and 2008.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.7
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows : Microsoft Bulletins

Nessus Plugin ID: 45513 ()

Bugtraq ID: 39303

CVE ID: CVE-2010-0480