OpenSSL < 0.9.8n Multiple Vulnerabilities

This script is Copyright (C) 2010-2015 Tenable Network Security, Inc.

Synopsis :

The remote web server has multiple SSL-related vulnerabilities.

Description :

According to its banner, the remote web server is running a version
of OpenSSL older than 0.9.8n. Such versions have the following
vulnerabilities :

- Kerberos-enabled versions of OpenSSL do not check
the return value when Kerberos configuration files
cannot be opened, leading to a crash. (CVE-2010-0433)

- Rejecting a SSL/TLS record with an incorrect version
number can lead to a crash. This only affects version
0.9.8m if a 'short' is 16 bits. Otherwise, it affects
all versions back to and including 0.9.8f.

See also :

Solution :

Upgrade to OpenSSL 0.9.8n or later.

Risk factor :

Medium / CVSS Base Score : 5.0
CVSS Temporal Score : 4.1
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 45359 ()

Bugtraq ID: 38533

CVE ID: CVE-2010-0433