Samba 'CAP_DAC_OVERRIDE' File Permission Security Bypass (version check)

This script is Copyright (C) 2010-2014 Tenable Network Security, Inc.

Synopsis :

The remote file server is vulnerable to a security bypass attack.

Description :

The remote Samba server is potentially affected by a security bypass
vulnerability because of a flaw that causes all smbd processes, when
libcap support is enabled, to inherit 'CAP_DAC_OVERRIDE' capabilities,
which in turn causes all file system access to be allowed even when
permissions should have been denied.

A remote, authenticated attacker may be able to exploit this flaw to
gain access to sensitive information on Samba shares that are
accessible to their user id.

See also :

Solution :

Upgrade to Samba 3.3.12, 3.4.7, 3.5.1, or later.

Risk factor :

High / CVSS Base Score : 8.5
CVSS Temporal Score : 7.0
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 45046 ()

Bugtraq ID: 38606

CVE ID: CVE-2010-0728