Apache < 1.3.42 mod_proxy Integer Overflow

This script is Copyright (C) 2010-2013 Tenable Network Security, Inc.


Synopsis :

The remote web server may be affected by an integer overflow
vulnerability.

Description :

According to its banner, the version of Apache 1.3 installed on the
remote host is older than 1.3.42. Such versions may allow a remote
attacker to overflow the heap by exploiting an integer overflow
vulnerability in mod_proxy Apache module.

Note that successful exploitation is possible only on platforms where
sizeof(int) < sizeof(long), such as 64-bit architectures.

Also note that version 1.3.42 is the final release of Apache
1.3.

See also :

http://site.pi3.com.pl/adv/mod_proxy.txt
http://archives.neohapsis.com/archives/fulldisclosure/2010-01/0589.html
http://www.nessus.org/u?2b8a4a59

Solution :

Either disable mod_proxy or upgrade to Apache version 1.3.42 or
later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.8
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 44589 (apache_1_3_42.nasl)

Bugtraq ID: 37966

CVE ID: CVE-2010-0010