Squid < 3.0.STABLE23 / 3.1.0.16

This script is Copyright (C) 2010-2014 Tenable Network Security, Inc.


Synopsis :

The remote proxy server is prone to a denial of service attack.

Description :

According to its banner, the version of the Squid proxy caching server
installed on the remote host is 2.x or older than 3.0.STABLE23 /
3.1.0.16. Such versions reportedly fail to correctly validate DNS
packets, which can be abused by a remote attack to cause a short-term
denial of service.

Note that Nessus has relied only on the version in the proxy server's
banner, which is not updated by either of the patches the project has
released to address this issue. If one of those has been applied
properly and the service restarted, consider this to be a false
positive.

See also :

http://www.squid-cache.org/Advisories/SQUID-2010_1.txt
http://www.nessus.org/u?9140f7e2
http://www.nessus.org/u?1e06892d
http://www.squid-cache.org/Versions/v2/HEAD/changesets/12597.patch

Solution :

Either upgrade to Squid version 3.0.STABLE23 / 3.1.0.16 or later or
apply the appropriate patch referenced in the project's advisory
above.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 4.1
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Firewalls

Nessus Plugin ID: 44384 ()

Bugtraq ID: 37522

CVE ID: CVE-2010-0308