OpenSSH < 4.7 Trusted X11 Cookie Connection Policy Bypass

This script is Copyright (C) 2011-2014 Tenable Network Security, Inc.


Synopsis :

Remote attackers may be able to bypass authentication.

Description :

According to the banner, OpenSSH earlier than 4.7 is running on the
remote host. Such versions contain an authentication bypass
vulnerability. In the event that OpenSSH cannot create an untrusted
cookie for X, for example due to the temporary partition being full,
it will use a trusted cookie instead. This allows attackers to
violate intended policy and gain privileges by causing their X client
to be treated as trusted.

See also :

http://www.openssh.com/txt/release-4.7

Solution :

Upgrade to OpenSSH 4.7 or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.2
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 44078 ()

Bugtraq ID: 25628

CVE ID: CVE-2007-4752
CVE-2007-2243