This script is Copyright (C) 2011 Tenable Network Security, Inc.
Remote attackers may be able to cause information to leak from
According to its banner, a version of OpenSSH earlier than 3.8p1 is
running on the remote host and is affected by the following issues:
- There is an issue in the handling of PAM modules in
such versions of OpenSSH. As a result, OpenSSH may not
correctly handle aborted conversations with PAM modules.
Consequently, that memory may not be scrubbed of
sensitive information such as credentials, which could
lead to credentials leaking into swap space and core
dumps. Other vulnerabilities in PAM modules could come
to light because of unpredictable behavior.
- Denial of service attacks are possible when privilege
separation is in use. This version of OpenSSH does not
properly signal non-privileged processes after session
termination when 'LoginGraceTime' is exceeded. This can
allow connections to remain open thereby allowing the
denial of service when resources are exhausted.
See also :
Upgrade to OpenSSH 3.8p1 or later.
Risk factor :
Medium / CVSS Base Score : 5.0
CVSS Temporal Score : 4.2
Public Exploit Available : false