Portable OpenSSH < 3.8p1 Multiple Vulnerabilities

This script is Copyright (C) 2011 Tenable Network Security, Inc.


Synopsis :

Remote attackers may be able to cause information to leak from
aborted sessions.

Description :

According to its banner, a version of OpenSSH earlier than 3.8p1 is
running on the remote host and is affected by the following issues:

- There is an issue in the handling of PAM modules in
such versions of OpenSSH. As a result, OpenSSH may not
correctly handle aborted conversations with PAM modules.
Consequently, that memory may not be scrubbed of
sensitive information such as credentials, which could
lead to credentials leaking into swap space and core
dumps. Other vulnerabilities in PAM modules could come
to light because of unpredictable behavior.

- Denial of service attacks are possible when privilege
separation is in use. This version of OpenSSH does not
properly signal non-privileged processes after session
termination when 'LoginGraceTime' is exceeded. This can
allow connections to remain open thereby allowing the
denial of service when resources are exhausted.
(CVE-2004-2069)

See also :

http://www.cl.cam.ac.uk/~mgk25/otpw.html#opensshbug
https://bugzilla.mindrot.org/show_bug.cgi?id=632
http://www.nessus.org/u?e86aec66
http://www.nessus.org/u?bb448083
http://www.nessus.org/u?d2f25e5c

Solution :

Upgrade to OpenSSH 3.8p1 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N)
CVSS Temporal Score : 4.2
(CVSS2#E:U/RL:U/RC:C)
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 44074 ()

Bugtraq ID: 9040
14963

CVE ID: CVE-2004-2069