OpenSSH < 3.2.3 YP Netgroups Authentication Bypass

This script is Copyright (C) 2011 Tenable Network Security, Inc.


Synopsis :

The remote SSH server has an authentication bypass vulnerability.

Description :

According to its banner, the version of OpenSSH running on the remote
host is older than 3.2.3. It therefore may be affected by an
authentication bypass issue. On systems using YP with netgroups, sshd
authenticates users via ACL by checking for the requested username and
password. Under certain conditions when doing ACL checks, it may
instead use the password entry of a different user for authentication.
This means unauthorized users could authenticate successfully, and
authorized users could be locked out.

See also :

http://monkey.org/openbsd/archive/bugs/0205/msg00141.html
http://www.openssh.org/txt/release-3.2.3
http://www.openbsd.org/errata31.html#sshbsdauth

Solution :

Upgrade to OpenSSH 3.2.3 or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.5
(CVSS2#E:H/RL:OF/RC:C)
Public Exploit Available : true

Family: Gain a shell remotely

Nessus Plugin ID: 44072 ()

Bugtraq ID: 4803

CVE ID: CVE-2002-0765