Serv-U < 9.1.0.0

This script is Copyright (C) 2009-2014 Tenable Network Security, Inc.


Synopsis :

The remote FTP server is affected by multiple vulnerabilities.

Description :

According to its banner, the installed version of Serv-U is earlier
than 9.1.0.0, and therefore affected by the following issues :

- A boundary error in the web administration interface
when parsing session cookies can result in a stack-based
buffer overflow. (CVE-2009-4873)

- A boundary error in the TEA decoding algorithm can
result in a stack-based buffer overflow when processing
a long hexadecimal string. (CVE-2009-4006)

See also :

http://www.rangos.de/ServU-ADV.txt
http://secunia.com/secunia_research/2009-46/
http://www.serv-u.com/releasenotes/

Solution :

Upgrade to Serv-U version 9.1.0.0 or later.

Risk factor :

High / CVSS Base Score : 9.0
(CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C)
CVSS Temporal Score : 7.4
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: FTP

Nessus Plugin ID: 42934 ()

Bugtraq ID: 36895
37051

CVE ID: CVE-2009-4006
CVE-2009-4873