GLSA-200911-01 : Horde: Multiple vulnerabilities

This script is Copyright (C) 2009-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200911-01
(Horde: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in Horde:
Stefan Esser of Sektion1 reported an error within the form library
when handling image form fields (CVE-2009-3236).
Martin
Geisler and David Wharton reported that an error exists in the MIME
viewer library when viewing unknown text parts and the preferences
system in services/prefs.php when handling number preferences
(CVE-2009-3237).

Impact :

A remote authenticated attacker could exploit these vulnerabilities to
overwrite arbitrary files on the server, provided that the user has
write permissions. A remote authenticated attacker could conduct
Cross-Site Scripting attacks.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200911-01.xml

Solution :

All Horde users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=www-apps/horde-3.3.5'
All Horde webmail users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=www-apps/horde-webmail-1.2.4'
All Horde groupware users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=www-apps/horde-groupware-1.2.4'

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 42415 (gentoo_GLSA-200911-01.nasl)

Bugtraq ID:

CVE ID: CVE-2009-3236
CVE-2009-3237