Apache 2.2.x < 2.2.14 Multiple Vulnerabilities

This script is Copyright (C) 2009-2015 Tenable Network Security, Inc.

Synopsis :

The remote web server is affected by multiple vulnerabilities.

Description :

According to its banner, the version of Apache 2.2.x running on the
remote host is prior to 2.2.14. It is, therefore, potentially affected
by multiple vulnerabilities :

- Faulty error handling in the Solaris pollset support
could lead to a denial of service. (CVE-2009-2699)

- The 'mod_proxy_ftp' module allows remote attackers to
bypass intended access restrictions. (CVE-2009-3095)

- The 'ap_proxy_ftp_handler' function in
'modules/proxy/proxy_ftp.c' in the 'mod_proxy_ftp'
module allows remote FTP servers to cause a
denial of service. (CVE-2009-3094)

Note that the remote web server may not actually be affected by these
vulnerabilities as Nessus did not try to determine whether the affected
modules are in use or check for the issues themselves.

See also :


Solution :

Upgrade to Apache version 2.2.14 or later. Alternatively, ensure that
the affected modules are not in use.

Risk factor :

High / CVSS Base Score : 7.5
CVSS Temporal Score : 6.2
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 42052 (apache_2_2_14.nasl)

Bugtraq ID: 36254

CVE ID: CVE-2009-2699