iTunes < 9.0.1 PLS File Buffer Overflow (Mac OS X)

This script is Copyright (C) 2009-2012 Tenable Network Security, Inc.

Synopsis :

The remote Mac OS X host contains an application affected by a buffer
overflow vulnerability.

Description :

The remote version of iTunes is older than 9.0.1. Such versions are
affected by a buffer overflow involving the handling of PLS files. If
an attacker can trick a user on the affected host into opening a
malicious PLS file, he can leverage this issue to crash the affected
application or to execute arbitrary code on the affected system
subject to the user's privileges.

See also :

Solution :

Upgrade to iTunes 9.0.1 or later.

Risk factor :

High / CVSS Base Score : 9.3
CVSS Temporal Score : 7.7
Public Exploit Available : true

Family: MacOS X Local Security Checks

Nessus Plugin ID: 41059 (macosx_itunes_9_0_1.nasl)

Bugtraq ID: 36478

CVE ID: CVE-2009-2817