Adobe Acrobat < 8.1.2 / 7.1.0 Multiple Vulnerabilities

This script is Copyright (C) 2009-2013 Tenable Network Security, Inc.


Synopsis :

The version of Adobe Acrobat on the remote Windows host is affected by
multiple vulnerabilities.

Description :

The version of Adobe Acrobat installed on the remote host is earlier
than 8.1.2 or 7.1.0. Such versions are reportedly affected by
multiple vulnerabilities :

- A design error vulnerability may allow an attacker to
gain control of a user's printer.

- Multiple stack-based buffer overflows may allow an
attacker to execute arbitrary code subject to the
user's privileges.

- Insecure loading of 'Security Provider' libraries may
allow for arbitrary code execution.

- An insecure method exposed by the JavaScript library
in the 'EScript.api' plug-in allows direct control
over low-level features of the object, which allows
for execution of arbitrary code as the current user.

- Two vulnerabilities in the unpublicized function
'app.checkForUpdate()' exploited through a callback
function could lead to arbitrary code execution in
Adobe Acrobat 7.

See also :

http://www.adobe.com/support/security/advisories/apsa08-01.html
http://www.adobe.com/support/security/bulletins/apsb08-13.html

Solution :

Upgrade to Adobe Acrobat 8.1.2 / 7.1.0 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:H/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 40800 (adobe_acrobat_812.nasl)

Bugtraq ID: 27641

CVE ID: CVE-2007-5659
CVE-2007-5663
CVE-2007-5666
CVE-2008-0655
CVE-2008-0667
CVE-2008-0726
CVE-2008-2042