Squid 3.0.STABLE16 / 3.10.11

This script is Copyright (C) 2009-2014 Tenable Network Security, Inc.


Synopsis :

The remote proxy server is prone to denial of service attacks.

Description :

According to its banner, the version of the Squid proxy caching server
installed on the remote host is older than 3.0.STABLE17 or 3.1.0.12.
Such versions reportedly use incorrect bounds checking when processing
some requests or responses.

Squid-2.x releases are not vulnerable.

See also :

http://www.squid-cache.org/Advisories/SQUID-2009_2.txt
http://www.securityfocus.com/advisories/17446
http://www.securityfocus.com/advisories/17448
http://www.securityfocus.com/advisories/17483

Solution :

Either upgrade to Squid version 3.0.STABLE17 or 3.1.0.12 or later or
apply the patch referenced in the project's advisory above.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 4.1
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Firewalls

Nessus Plugin ID: 40420 ()

Bugtraq ID: 35812

CVE ID: CVE-2009-2621
CVE-2009-2622