CommuniGate Pro WebMail < 5.2.15 XSS

This script is Copyright (C) 2009-2012 Tenable Network Security, Inc.


Synopsis :

The remote web server is affected by a cross-site scripting
vulnerability.

Description :

According to its banner, the remote web server is from a version of
CommuniGate Pro older than 5.2.15. The webmail component of such
versions fails to correctly parse plain text email messages containing
malicious URL links before displaying the message to the user. By
sending a specially crafted email message to the victim's email
address, an attacker may be able to leverage this issue to execute
arbitrary JavaScript code within the user's browser session every time
the email message is read.

See also :

http://www.nessus.org/u?3ba42c1d
http://archives.neohapsis.com/archives/bugtraq/2009-07/0174.html
http://www.communigate.com/cgatepro/History52.html

Solution :

Upgrade to CommuniGate Pro 5.2.15 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 3.6
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: CGI abuses : XSS

Nessus Plugin ID: 40418 (communigatepro_5_2_15.nasl)

Bugtraq ID: 35783

CVE ID: