VMSA-2008-0009 : Updates to VMware Workstation, VMware Player, VMware ACE, VMware Fusion, VMware Server, VMware VIX API, VMware ESX, VMware ESXi resolve critical security issues

This script is Copyright (C) 2009-2013 Tenable Network Security, Inc.


Synopsis :

The remote VMware ESXi / ESX host is missing one or more
security-related patches.

Description :

a. VMware Tools Local Privilege Escalation on Windows-based guest OS

The VMware Tools Package provides support required for shared folders
(HGFS) and other features.

An input validation error is present in the Windows-based VMware
HGFS.sys driver. Exploitation of this flaw might result in
arbitrary code execution on the guest system by an unprivileged
guest user. It doesn't matter on what host the Windows guest OS
is running, as this is a guest driver vulnerability and not a
vulnerability on the host.

The HGFS.sys driver is present in the guest operating system if the
VMware Tools package is loaded. Even if the host has HGFS disabled
and has no shared folders, Windows-based guests may be affected. This
is regardless if a host supports HGFS.

This issue could be mitigated by removing the VMware Tools package
from Windows based guests. However this is not recommended as it
would impact usability of the product.

NOTE: Installing the new hosted release or ESX patches will not
remediate the issue. The VMware Tools packages will need
to be updated on each Windows-based guest followed by a
reboot of the guest system.

VMware would like to thank iDefense and Stephen Fewer of Harmony
Security for reporting this issue to us.

The Common Vulnerabilities and Exposures project (cve.mitre.org)
has assigned the name CVE-2007-5671 to this issue.

b. Privilege escalation on ESX or Linux based hosted operating systems

This update fixes a security issue related to local exploitation of
an untrusted library path vulnerability in vmware-authd. In order to
exploit this vulnerability, an attacker must have local access and
the ability to execute the set-uid vmware-authd binary on an affected
system. Exploitation of this flaw might result in arbitrary code
execution on the Linux host system by an unprivileged user.

VMware would like to thank iDefense for reporting this issue to us.

The Common Vulnerabilities and Exposures project (cve.mitre.org)
has assigned the name CVE-2008-0967 to this issue.

c. Openwsman Invalid Content-Length Vulnerability

Openwsman is a system management platform that implements the Web
Services Management protocol (WS-Management). It is installed and
running by default. It is used in the VMware Management Service
Console and in ESXi.

The openwsman management service on ESX 3.5 and ESXi 3.5 is vulnerable
to a privilege escalation vulnerability, which may allow users with
non-privileged ESX or Virtual Center accounts to gain root privileges.

To exploit this vulnerability, an attacker would need a local ESX
account or a VirtualCenter account with the Host.Cim.CimInteraction
permission.

Systems with no local ESX accounts and no VirtualCenter accounts with
the Host.Cim.CimInteraction permission are not vulnerable.

This vulnerability cannot be exploited by users without valid login
credentials.

Discovery: Alexander Sotirov, VMware Security Research

The Common Vulnerabilities and Exposures project (cve.mitre.org)
has assigned the name CVE-2008-2097 to this issue.

d. VMware VIX Application Programming Interface (API) Memory Overflow
Vulnerabilities

The VIX API (also known as 'Vix') is an API that lets users write scripts
and programs to manipulate virtual machines.

Multiple buffer overflow vulnerabilities are present in the VIX API.
Exploitation of these vulnerabilities might result in a privilege
escalation on the host system. This exploit scenario is relevant for all
affected products. On VC, ESX30x, and ESX35, users need to have the VM
Interaction Privilege in order to exploit the vulnerability.

Exploitation of these vulnerabilities might also result in code execution on
the host system from the guest system or on the service console in ESX Server
from the guest operating system. This exploit scenario is relevant for
Workstation 6.0.x (version 6.0.3 and below), Player 2.0.x (version 2.0.3 and
below), ACE 2.0.x (version 2.0.3 and below), Server 1.0.x (version 1.0.5 and
below), and ESX3.5. The parameter 'vix.inGuest.enable' in the VMware
configuration file must be set to true to allow for exploitation on these
products. Note that the parameter 'vix-inGuest.enable' is set to false by
default.

The parameter 'vix.inGuest.enable' is present in the
following products :

VMware Workstation 6.0.2 and higher
VMware ACE 6.0.2 and higher
VMware Server 1.06 and higher
VMware Fusion 1.1.2 and higher
ESX Server 3.0 and higher
ESX Server 3.5 and higher

In previous versions of VMware products where the VIX API was introduced,
the VIX API couldn't be disabled.

This vulnerability is present in ESX and the hosted products even if you
have not installed the VIX API. To patch your system you will need to
update to the new hosted product version or to apply the appropriate ESX
patch. It is not necessary to update the VIX API if you have installed
the VIX API.

VMware would like to thank Andrew Honig of the Department of
Defense for reporting this issue.

The Common Vulnerabilities and Exposures project (cve.mitre.org)
has assigned the name CVE-2008-2100 to this issue.

II Service Console rpm updates

NOTE: ESXi and hosted products are not affected by any service console
security updates

a. Security update for cyrus-sasl

Updated cyrus-sasl package for the ESX Service Console corrects a security
issue found in the DIGEST-MD5 authentication mechanism of Cyrus'
implementation of Simple Authentication and Security Layer (SASL). As a
result of this issue in the authentication mechanism, a remote
unauthenticated attacker might be able to cause a denial of service error
on the service console.

The Common Vulnerabilities and Exposures project (cve.mitre.org) has
assigned the name CVE-2006-1721 to this issue.

b. Security update for tcltk

An input validation flaw was discovered in Tk's GIF image handling. A
code-size value read from a GIF image was not properly validated before
being used, leading to a buffer overflow. A specially crafted GIF file
could use this to cause a crash or, potentially, execute code with the
privileges of the application using the Tk graphical toolkit.

The Common Vulnerabilities and Exposures project (cve.mitre.org) has
assigned the name CVE-2008-0553 to this issue.

A buffer overflow flaw was discovered in Tk's animated GIF image handling.
An animated GIF containing an initial image smaller than subsequent images
could cause a crash or, potentially, execute code with the privileges of
the application using the Tk library.

The Common Vulnerabilities and Exposures project (cve.mitre.org) has
assigned the name CVE-2007-5378 to this issue.

A flaw first discovered in the Tcl regular expression engine used in the
PostgreSQL database server, resulted in an infinite loop when processing
certain regular expressions.

The Common Vulnerabilities and Exposures project (cve.mitre.org) has
assigned the name CVE-2007-4772 to this issue.

c. Security update for unzip

This patch includes a moderate security update to the service console that
fixes a flaw in unzip. An attacker could execute malicious code with a
user's privileges if the user ran unzip on a file designed to leverage
this flaw.

The Common Vulnerabilities and Exposures project (cve.mitre.org) has
assigned the name CVE-2008-0888 to this issue.

d. Security update for krb5

KDC in MIT Kerberos 5 (krb5kdc) does not set a global variable
for some krb4 message types, which allows remote attackers to
cause a denial of service (crash) and possibly execute arbitrary
code via crafted messages that trigger a NULL pointer dereference
or double-free.

The Common Vulnerabilities and Exposures project (cve.mitre.org)
has assigned the name CVE-2008-0062 to this issue.

NOTE: ESX doesn't contain the krb5kdc binary and is not vulnerable
to this issue.

The Kerberos 4 support in KDC in MIT Kerberos 5 (krb5kdc) does not
properly clear the unused portion of a buffer when generating an
error message, which might allow remote attackers to obtain
sensitive information, aka 'Uninitialized stack values.'

The Common Vulnerabilities and Exposures project (cve.mitre.org)
has assigned the name CVE-2008-0063 to this issue.

NOTE: ESX doesn't contain the krb5kdc binary and is not vulnerable
to this issue.

Buffer overflow in the RPC library (lib/rpc/rpc_dtablesize.c) used
by libgssrpc and kadmind in MIT Kerberos 5 (krb5) 1.2.2, and probably
other versions before 1.3, when running on systems whose unistd.h
does not define the FD_SETSIZE macro, allows remote attackers to cause
a denial of service (crash) and possibly execute arbitrary code by
triggering a large number of open file descriptors.

The Common Vulnerabilities and Exposures project (cve.mitre.org)
has assigned the name CVE-2008-0948 to this issue.

See also :

http://lists.vmware.com/pipermail/security-announce/2008/000022.html

Solution :

Apply the missing patches.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true