GLSA-200906-01 : libpng: Information disclosure

This script is Copyright (C) 2009-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200906-01
(libpng: Information disclosure)

Jeff Phillips discovered that libpng does not properly parse 1-bit
interlaced images with width values that are not divisible by 8, which
causes libpng to include uninitialized bits in certain rows of a PNG
file.

Impact :

A remote attacker might entice a user to open a specially crafted PNG
file, possibly resulting in the disclosure of sensitive memory
portions.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200906-01.xml

Solution :

All libpng users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=media-libs/libpng-1.2.37'

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N)
CVSS Temporal Score : 3.2
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Gentoo Local Security Checks

Nessus Plugin ID: 39561 (gentoo_GLSA-200906-01.nasl)

Bugtraq ID: 35233

CVE ID: CVE-2009-2042