Samba < 3.0.35 / 3.2.13 / 3.3.6 Multiple Vulnerabilities

This script is Copyright (C) 2009-2011 Tenable Network Security, Inc.


Synopsis :

The remote Samba server may be affected by a security bypass
vulnerability.

Description :

According to its version number, the version of Samba running on the
remote host has a security bypass vulnerability. Access restrictions
can be bypassed due to a read of uninitialized data in smbd. This
could allow a user to modify an access control list (ACL), even when
they should be denied permission.

Note the 'dos filemode' parameter must be set to 'yes' in smb.conf
in order for an attack to be successful (the default setting is 'no').

Also note versions 3.2.0 - 3.2.12 of smbclient are affected by a
format string vulnerability, though Nessus has not checked for this.

See also :

http://us1.samba.org/samba/security/CVE-2009-1888.html
http://us1.samba.org/samba/security/CVE-2009-1886.html

Solution :

Upgrade to Samba version 3.3.6 / 3.2.13 / 3.0.35 or later, or apply
the appropriate patch referenced in the vendor's advisory.

Risk factor :

Low / CVSS Base Score : 3.5
(CVSS2#AV:N/AC:M/Au:S/C:N/I:P/A:N)
CVSS Temporal Score : 2.7
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 39502 ()

Bugtraq ID: 35472

CVE ID: CVE-2009-1886
CVE-2009-1888
CVE-2006-3403