RHEL 4 / 5 : libwmf (RHSA-2009:0457)

This script is Copyright (C) 2009-2014 Tenable Network Security, Inc.


Synopsis :

The remote Red Hat host is missing one or more security updates.

Description :

Updated libwmf packages that fix one security issue are now available
for Red Hat Enterprise Linux 4 and 5.

This update has been rated as having moderate security impact by the
Red Hat Security Response Team.

libwmf is a library for reading and converting Windows Metafile Format
(WMF) vector graphics. libwmf is used by applications such as GIMP and
ImageMagick.

A pointer use-after-free flaw was found in the GD graphics library
embedded in libwmf. An attacker could create a specially crafted WMF
file that would cause an application using libwmf to crash or,
potentially, execute arbitrary code as the user running the
application when opened by a victim. (CVE-2009-1364)

Note: This flaw is specific to the GD graphics library embedded in
libwmf. It does not affect the GD graphics library from the 'gd'
packages, or applications using it.

Red Hat would like to thank Tavis Ormandy of the Google Security Team
for responsibly reporting this flaw.

All users of libwmf are advised to upgrade to these updated packages,
which contain a backported patch to correct this issue. After
installing the update, all applications using libwmf must be restarted
for the update to take effect.

See also :

https://www.redhat.com/security/data/cve/CVE-2009-1364.html
http://rhn.redhat.com/errata/RHSA-2009-0457.html

Solution :

Update the affected libwmf and / or libwmf-devel packages.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Red Hat Local Security Checks

Nessus Plugin ID: 38659 ()

Bugtraq ID:

CVE ID: CVE-2009-1364