DB2 9.1 < Fix Pack 7 Multiple Vulnerabilities

This script is Copyright (C) 2009-2014 Tenable Network Security, Inc.


Synopsis :

The remote database server is affected by multiple issues.

Description :

According to its version, the installed version of DB2 server is older
than 9.1 Fix Pack 7. Such versions are reportedly affected by multiple
issues :

- In certain situations an INNER JOIN predicate is applied
before the OUTER JOIN predicate, which could result in
disclosure of sensitive information. (JR31886)

- It may be possible to connect to DB2 servers without
valid passwords, provided LDAP-based authentication
is used, and the remote LDAP server is configured to
allow anonymous binds. (JR32272)

- By connecting to a DB2 server using a third-party DRDA
client that uses IPV6 address format of the correlation
token, it may be possible to crash the remote DB2
server. (IZ36683)

See also :

http://www-01.ibm.com/support/docview.wss?rs=71&uid=swg21255607#7
http://www-01.ibm.com/support/docview.wss?uid=swg1JR31886
http://www-01.ibm.com/support/docview.wss?uid=swg1JR32272
http://www-01.ibm.com/support/docview.wss?uid=swg1IZ36683

Solution :

Apply DB2 Version 9.1 Fix Pack 7 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N)
CVSS Temporal Score : 4.1
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Databases

Nessus Plugin ID: 36216 (db2_9fp7.nasl)

Bugtraq ID: 34650
35171

CVE ID: CVE-2009-1239
CVE-2009-1905
CVE-2009-1906