GLSA-200903-36 : MLDonkey: Information disclosure

This script is Copyright (C) 2009-2015 Tenable Network Security, Inc.

Synopsis :

The remote Gentoo host is missing one or more security-related

Description :

The remote host is affected by the vulnerability described in GLSA-200903-36
(MLDonkey: Information disclosure)

Michael Peselnik reported that src/utils/lib/ in the web
interface of MLDonkey does not handle file names with leading double
slashes properly.

Impact :

A remote attacker could gain access to arbitrary files readable by the
user running the application.

Workaround :

Disable the web interface or restrict access to it.

See also :

Solution :

All MLDonkey users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-p2p/mldonkey-3.0.0'

Risk factor :

Medium / CVSS Base Score : 5.0

Family: Gentoo Local Security Checks

Nessus Plugin ID: 36002 (gentoo_GLSA-200903-36.nasl)

Bugtraq ID:

CVE ID: CVE-2009-0753