GLSA-200903-25 : Courier Authentication Library: SQL Injection vulnerability

This script is Copyright (C) 2009-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200903-25
(Courier Authentication Library: SQL Injection vulnerability)

It has been reported that some parameters used in SQL queries are not
properly sanitized before being processed when using a non-Latin locale
Postgres database.

Impact :

A remote attacker could send specially crafted input to an application
using the library, possibly resulting in the execution of arbitrary SQL
commands.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200903-25.xml

Solution :

All Courier Authentication Library users should upgrade to the latest
version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-libs/courier-authlib-0.62.2'

Risk factor :

Medium / CVSS Base Score : 5.1
(CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 35912 (gentoo_GLSA-200903-25.nasl)

Bugtraq ID:

CVE ID: CVE-2008-2380