GLSA-200903-08 : gEDA: Insecure temporary file creation

This script is Copyright (C) 2009-2015 Tenable Network Security, Inc.

Synopsis :

The remote Gentoo host is missing one or more security-related

Description :

The remote host is affected by the vulnerability described in GLSA-200903-08
(gEDA: Insecure temporary file creation)

Dmitry E. Oboukhov reported an insecure temporary file usage within the script.

Impact :

A local attacker could perform symlink attacks to overwrite arbitrary
files with the privileges of the user running the application.

Workaround :

There is no known workaround at this time.

See also :

Solution :

All gEDA users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=sci-electronics/geda-1.4.0-r1'

Risk factor :

Medium / CVSS Base Score : 6.9

Family: Gentoo Local Security Checks

Nessus Plugin ID: 35798 (gentoo_GLSA-200903-08.nasl)

Bugtraq ID:

CVE ID: CVE-2008-5148