GLSA-200903-07 : Samba: Data disclosure

This script is Copyright (C) 2009-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200903-07
(Samba: Data disclosure)

Samba does not properly check memory boundaries when handling trans,
rans2, and nttrans requests.

Impact :

A remote attacker could send specially crafted requests to a Samba
daemon, leading to the disclosure of arbitrary memory or to a Denial of
Service.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200903-07.xml

Solution :

All Samba users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-fs/samba-3.0.33'

Risk factor :

High / CVSS Base Score : 8.5
(CVSS2#AV:N/AC:L/Au:N/C:C/I:N/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 35797 (gentoo_GLSA-200903-07.nasl)

Bugtraq ID:

CVE ID: CVE-2008-4314