Kerio MailServer < 6.6.2 Multiple XSS (KSEC-2008-12-16-01)

This script is Copyright (C) 2008-2012 Tenable Network Security, Inc.


Synopsis :

The remote mail server is affected by several cross-site scripting
vulnerabilities.

Description :

According to its banner, the remote host is running a version of Kerio
MailServer prior to 6.6.2. Multiple files in such versions are
reportedly affected by cross-site scripting vulnerabilities.

- The application fails to sanitize input to the parameter
'folder' of the 'mailCompose.php' script as well as the
parameter 'daytime' of the 'calendarEdit.php' script
before using it to generate dynamic HTML.

- Content passed to 'sent' parameter of the 'error413.php'
script is not sanitized before being returned to the
user.

Successful exploitation of these issues could lead to execution of
arbitrary HTML and script code in a user's browser within the security
context of the affected site.

See also :

http://www.kerio.com/security_advisory.html#0812

Solution :

Upgrade to Kerio MailServer 6.6.2 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 3.6
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: CGI abuses : XSS

Nessus Plugin ID: 35258 (kerio_kms_662.nasl)

Bugtraq ID: 32863

CVE ID: CVE-2008-5760
CVE-2008-5769