RHEL 2.1 / 3 / 4 : enscript (RHSA-2008:1021)

This script is Copyright (C) 2008-2014 Tenable Network Security, Inc.


Synopsis :

The remote Red Hat host is missing a security update.

Description :

An updated enscript packages that fixes several security issues is now
available for Red Hat Enterprise Linux 2.1, 3, and 4.

This update has been rated as having moderate security impact by the
Red Hat Security Response Team.

GNU enscript converts ASCII files to PostScript(R) language files and
spools the generated output to a specified printer or saves it to a
file. Enscript can be extended to handle different output media and
includes options for customizing printouts.

Several buffer overflow flaws were found in GNU enscript. An attacker
could craft an ASCII file in such a way that it could execute
arbitrary commands if the file was opened with enscript with the
'special escapes' option (-e or --escapes) enabled. (CVE-2008-3863,
CVE-2008-4306, CVE-2008-5078)

All users of enscript should upgrade to these updated packages, which
contain backported patches to correct these issues.

See also :

https://www.redhat.com/security/data/cve/CVE-2008-3863.html
https://www.redhat.com/security/data/cve/CVE-2008-4306.html
https://www.redhat.com/security/data/cve/CVE-2008-5078.html
http://rhn.redhat.com/errata/RHSA-2008-1021.html

Solution :

Update the affected enscript package.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)

Family: Red Hat Local Security Checks

Nessus Plugin ID: 35180 ()

Bugtraq ID:

CVE ID: CVE-2008-3863
CVE-2008-4306
CVE-2008-5078